[RESOLVED] Reports of inconsistent publishing results for some sites

Incident Report for Webflow

Resolved

Some sites experienced inconsistent publishing results. During this time, an older version of a site was not always cleared as expected after a new publish. We’re no longer seeing customer impact related to this issue, and this incident is now resolved. Thank you for your patience while we worked through this.
Posted Mar 16, 2026 - 23:52 UTC

Identified

We’re currently awaiting a fix from an upstream provider. For some customers, waiting 10–15 minutes and then trying to publish again may help. We’ll share another update as soon as we have more information.
Posted Mar 16, 2026 - 22:44 UTC

Investigating

We’re investigating reports that some customers may see issues when publishing their sites. This can result in inconsistent publishing behavior, where an older version of a site is not always cleared as expected after a new publish. Our team is actively investigating and working with an upstream provider. We’ll share another update as soon as we have more information.
Posted Mar 16, 2026 - 20:40 UTC
This incident affected: Publishing.