Degraded performance in Designer and Dashboard

Incident Report for Webflow

Resolved

The incident has been resolved.
Posted Jun 19, 2023 - 18:14 UTC

Monitoring

We have implemented a fix and are continuing to monitor the situation.
Posted Jun 19, 2023 - 17:42 UTC

Identified

We have identified the issue and are working on a fix.
Posted Jun 19, 2023 - 17:24 UTC

Investigating

Webflow is investigating reports of degraded performance in the Designer and Dashboard.

No user action is required at this time.
Posted Jun 19, 2023 - 15:58 UTC
This incident affected: Dashboard, Designer, and Publishing.