Reports of form submissions failing on some sites

Incident Report for Webflow

Resolved

Our upstream provider has implemented a fix. The issue is now resolved.
Posted Apr 29, 2023 - 10:43 UTC

Identified

The issue has been identified as caused by an upstream provider. We are currently working on a fix.
Posted Apr 29, 2023 - 09:02 UTC

Investigating

Webflow is investigating reports of form submissions failing on some sites.
Posted Apr 29, 2023 - 08:11 UTC
This incident affected: Hosted Websites (Static pages).