[RESOLVED] Reports of 503 errors on some hosted sites, Webflow.com, and MCP Server

Incident Report for Webflow

Resolved

This incident has been resolved.
Posted Aug 25, 2026 - 23:58 UTC

Update

Some hosted sites, Webflow.com, and MCP Server experienced 503 errors. We’re no longer seeing customer impact related to this issue, and the incident is now resolved.

We appreciate your patience while we worked to resolve this issue.
Posted Aug 25, 2026 - 23:57 UTC

Monitoring

We’re seeing services return to expected performance levels and are no longer seeing active customer impact related to this issue. Our team is continuing to monitor the situation closely.
Posted Aug 25, 2026 - 22:09 UTC

Investigating

We’re continuing to investigate reports of 503 errors affecting some hosted sites, Webflow.com, and MCP Server. Our team is actively investigating and will share another update as soon as we have more information.
Posted Aug 25, 2026 - 22:00 UTC
This incident affected: Webflow.com & Marketplace (Webflow.com, Support Portal, Marketplace) and API & MCP Server (MCP Server).