Reports of issues loading some Hosted Sites and with Publishing

Incident Report for Webflow

Resolved

This incident has been resolved.
Posted Jun 07, 2025 - 17:30 UTC

Update

This incident has been resolved but we'll continue monitoring the results.
Posted Jun 07, 2025 - 17:15 UTC

Monitoring

We've identified the issue and a fix has been implemented. We're monitoring the results.
Posted Jun 07, 2025 - 16:42 UTC

Update

We’re continuing to investigate issues impacting hosted sites, publishing, the Designer, and the Dashboard.
Posted Jun 07, 2025 - 15:46 UTC

Investigating

We've recognized increased latency leading to some 504 errors and failures publishing. We're continuing our investigation into root causes.
Posted Jun 07, 2025 - 14:50 UTC
This incident affected: Hosted Websites (Static pages, CMS pages) and Dashboard, Designer, Publishing.