[RESOLVED] Reports of issues viewing custom domains in the publishing modal for some customers

Incident Report for Webflow

Resolved

A small number of customers experienced issues where custom domains were not appearing as expected in the publishing modal between Mar 30, 18:00 UTC and Mar 31, 18:30 UTC.

A fix has been implemented, and we’re no longer seeing customer impact related to this issue.

Thank you for your patience while we worked to resolve this.
Posted Mar 31, 2026 - 19:02 UTC

Monitoring

A fix has been implemented for the issue where custom domains were not appearing as expected in the publishing modal for a small number of customers.

We’re no longer seeing customer impact and are continuing to monitor the situation closely.

Thank you for your patience while we worked through this.
Posted Mar 31, 2026 - 18:39 UTC

Update

We’ve identified the root cause of this issue and are making progress toward a fix.

Our team is actively working on implementing and validating the solution to ensure custom domains display as expected in the publishing modal. In the meantime, reloading the project may still help domains appear correctly for some customers.

We’ll continue to share updates as progress is made.
Posted Mar 31, 2026 - 18:14 UTC

Identified

We’ve identified the root cause of the issue impacting a small number of customers where custom domains may not appear as expected in the publishing modal.

Our team is actively working on implementing a fix. In the meantime, reloading the project may still result in domains displaying as expected.

We’ll share another update as soon as more information becomes available.
Posted Mar 31, 2026 - 16:55 UTC

Investigating

We’re currently investigating reports that domains are not appearing as expected in the publishing modal for a small number customers. Our team is actively looking into the issue and will share another update as soon as we have more information.

In the meantime, reloading your project may result in your domains displaying as expected inside the publishing modal.
Posted Mar 31, 2026 - 15:33 UTC
This incident affected: Publishing.