[RESOLVED] Reports of intermittent errors for hosted sites

Incident Report for Webflow

Resolved

After a period of monitoring, we can confirm our mitigation was successful and site performance has returned to expected levels. This incident is now resolved.

Some hosted pages with CMS content may have experienced intermittent 5xx errors during the following windows each lasting a few minutes (UTC):

- 01:27–01:31
- 01:39–01:41
- 01:51–01:53
- 04:47–04:50
- 05:02–05:03

We appreciate your patience while we worked to investigate and resolve the issue.
Posted Jul 19, 2026 - 14:00 UTC

Monitoring

We’re no longer seeing customer impact related to this issue, and hosted sites are performing as expected.

Our team has implemented mitigations and is continuing to monitor the situation closely. We’ll continue to observe service performance and provide another update if there are any significant changes.

We appreciate your patience while we worked to investigate this incident.
Posted Jul 19, 2026 - 06:10 UTC

Investigating

We’re investigating reports of intermittent errors affecting hosted sites. While we previously observed a period of recovery, we’re continuing to see customer impact and are actively investigating the issue.

Our engineering team is working with urgency to identify the root cause and restore expected performance. We’ll share another update as soon as more information becomes available.
Posted Jul 19, 2026 - 05:14 UTC
This incident affected: Hosted Websites (Site Pages).