[RESOLVED] Reports of issues accessing Webflow Canvas via Client Seats

Incident Report for Webflow

Resolved

This incident has been resolved.
Posted Apr 01, 2026 - 14:51 UTC

Update

We are continuing to monitor for any further issues.
Posted Apr 01, 2026 - 14:14 UTC

Monitoring

A fix has been implemented for the issue impacting some customers with a Client seat role who were unable to access Webflow Canvas. We are seeing recovery and are continuing to monitor the situation closely to ensure stability.
Posted Apr 01, 2026 - 14:13 UTC

Identified

We have identified the root cause of this behavior and are actively working to implement a fix as soon as possible.
Posted Apr 01, 2026 - 13:59 UTC

Investigating

We’re investigating reports of authorization errors when accessing the Webflow Canvas using Client seats.
Our team is actively investigating and will share another update as soon as we have another update to share.
Posted Apr 01, 2026 - 13:43 UTC
This incident affected: Webflow Canvas.