Reports of form submissions failing on some sites
Incident Report for Webflow
Resolved
This incident has been resolved.
Posted Apr 29, 2023 - 23:08 UTC
Monitoring
The team has deployed a fix and we are monitoring the situation.
Posted Apr 29, 2023 - 22:48 UTC
Identified
The team has identified the issue and is continuing to work on a fix.
Posted Apr 29, 2023 - 22:20 UTC
Investigating
One of Webflow’s upstream providers is having issues with their services. We are investigating reports of form submissions failing on some sites.
Posted Apr 29, 2023 - 21:23 UTC
This incident affected: Hosted Websites (Static pages).