Dashboard and Designer Degradation
Incident Report for Webflow
Resolved
This incident has been resolved.
Posted Jun 19, 2020 - 16:38 UTC
Monitoring
We've reverted the change that caused the issue and are monitoring.
Posted Jun 19, 2020 - 16:37 UTC
Identified
Webflow is experiencing an issue causing the dashboard and designer to fail to load. The problem has been identified and a fix is being applied.
Posted Jun 19, 2020 - 16:28 UTC
This incident affected: Dashboard.