Reports of issues loading some Hosted Sites, the Dashboard & the Designer

Incident Report for Webflow

Resolved

This incident has been resolved.
Posted Jun 03, 2025 - 23:04 UTC

Monitoring

We are seeing improvements and are continuing to monitor. A republish may help resolve any errors still being returned on hosted sites.
Posted Jun 03, 2025 - 17:56 UTC

Update

We're continuing to investigate issues loading some Hosted Sites, the Dashboard & the Designer. Sites may be experiencing slow publishing behavior as well.
Posted Jun 03, 2025 - 16:55 UTC

Update

We are continuing to investigate this issue.
Posted Jun 03, 2025 - 14:19 UTC

Update

We are continuing to investigate this issue.
Posted Jun 03, 2025 - 14:18 UTC

Investigating

We're continuing to investigate issues loading hosted sites and also 504 errors when loading the Designer
Posted Jun 03, 2025 - 13:59 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Jun 03, 2025 - 09:54 UTC

Identified

We've identified the issue and are working to mitigate any problems that may have arisen.
Posted Jun 03, 2025 - 07:48 UTC

Update

We are currently investigating an issue affecting some hosted sites, which may return 504 or 404 error on some pages. Users may also experience delays when publishing updates.
Posted Jun 03, 2025 - 05:57 UTC

Investigating

Webflow is investigating reports of intermittent issues loading some hosted sites.
Posted Jun 03, 2025 - 05:02 UTC
This incident affected: Hosted Websites (Static pages, CMS pages) and Dashboard, Designer, Publishing.