Dashboard/Designer latency
Incident Report for Webflow
Resolved
We've resolved the latency issues - we'll continue monitoring system status closely.
Posted almost 2 years ago. Dec 10, 2015 - 18:25 UTC
Investigating
We're currently investigating reports of high latency in the dashboard and designer
Posted almost 2 years ago. Dec 10, 2015 - 17:58 UTC