CloudFront CDN Outage
Incident Report for Webflow
Resolved
It looks like Amazon CloudFront issues have been resolved, and Webflow should be back to normal. If you're having any issues with Webflow, please let us know by contacting support@webflow.com - thank you for your patience!
Posted almost 3 years ago. Nov 27, 2014 - 02:09 UTC
Identified
Amazon CloudFront, our CDN, is failing to serve Webflow resources. This is causing our application to be unresponsive. We are investigating, and will keep you updated as we learn more. We apologize for the inconvenience!
Posted almost 3 years ago. Nov 27, 2014 - 01:30 UTC